diff options
author | FxQnLr <[email protected]> | 2024-02-26 15:50:00 +0100 |
---|---|---|
committer | GitHub <[email protected]> | 2024-02-26 15:50:00 +0100 |
commit | 31a57425a76cae121c5d8ef5b0f2442ca6a9ee61 (patch) | |
tree | 19151fea3c1548d6298c0fb819e2a776d9aca74a /Cargo.toml | |
parent | 0967f44161e972ff1a8482fd168897a3b183bae3 (diff) | |
parent | ffedfd00a46147b225c834187fc298e88e60d0c5 (diff) | |
download | webol-cli-31a57425a76cae121c5d8ef5b0f2442ca6a9ee61.tar webol-cli-31a57425a76cae121c5d8ef5b0f2442ca6a9ee61.tar.gz webol-cli-31a57425a76cae121c5d8ef5b0f2442ca6a9ee61.zip |
Merge pull request #7 from FxQnLr/webol-dev-9
Webol dev 9
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 27 |
1 files changed, 14 insertions, 13 deletions
@@ -1,6 +1,6 @@ | |||
1 | [package] | 1 | [package] |
2 | name = "webol-cli" | 2 | name = "webol-cli" |
3 | version = "0.1.0" | 3 | version = "0.2.0" |
4 | edition = "2021" | 4 | edition = "2021" |
5 | 5 | ||
6 | # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html | 6 | # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html |
@@ -10,15 +10,16 @@ name = "webol" | |||
10 | path = "src/main.rs" | 10 | path = "src/main.rs" |
11 | 11 | ||
12 | [dependencies] | 12 | [dependencies] |
13 | clap = { version = "4.4.6", features = ["derive"] } | 13 | anyhow = "1.0" |
14 | clap_complete = "4.4.4" | 14 | clap = { version = "4.5", features = ["derive"] } |
15 | config = "0.13.3" | 15 | clap_complete = "4.5" |
16 | dirs = "5.0.1" | 16 | config = "0.14" |
17 | futures-util = "0.3.29" | 17 | dirs = "5.0" |
18 | indicatif = "0.17.7" | 18 | futures-util = "0.3" |
19 | once_cell = "1.18.0" | 19 | indicatif = "0.17" |
20 | reqwest = { version = "0.11.22", features = ["blocking"] } | 20 | reqwest = { version = "0.11", features = ["blocking"] } |
21 | serde = "1.0.189" | 21 | serde = "1.0" |
22 | serde_json = "1.0.107" | 22 | serde_json = "1.0" |
23 | tokio = { version = "1.33.0", features = ["macros", "rt-multi-thread", "io-std"] } | 23 | thiserror = "1.0" |
24 | tokio-tungstenite = "0.20.1" | 24 | tokio = { version = "1.36", features = ["macros", "rt-multi-thread", "io-std"] } |
25 | tokio-tungstenite = "0.21" | ||