diff options
author | FxQnLr <[email protected]> | 2024-02-25 16:14:56 +0100 |
---|---|---|
committer | FxQnLr <[email protected]> | 2024-02-25 16:14:56 +0100 |
commit | 03bea24f9de698375033af92a08762446d0e20cc (patch) | |
tree | 71b696ddcdc14f36115155be7f287fc0cb43e16d /Cargo.toml | |
parent | cd73d51fba4a7d24b5ef12cb7d23054ab922cb67 (diff) | |
download | webol-cli-03bea24f9de698375033af92a08762446d0e20cc.tar webol-cli-03bea24f9de698375033af92a08762446d0e20cc.tar.gz webol-cli-03bea24f9de698375033af92a08762446d0e20cc.zip |
Closes #2. Config and setup stuff
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 25 |
1 files changed, 12 insertions, 13 deletions
@@ -1,6 +1,6 @@ | |||
1 | [package] | 1 | [package] |
2 | name = "webol-cli" | 2 | name = "webol-cli" |
3 | version = "0.1.0" | 3 | version = "0.2.0" |
4 | edition = "2021" | 4 | edition = "2021" |
5 | 5 | ||
6 | # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html | 6 | # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html |
@@ -10,15 +10,14 @@ name = "webol" | |||
10 | path = "src/main.rs" | 10 | path = "src/main.rs" |
11 | 11 | ||
12 | [dependencies] | 12 | [dependencies] |
13 | clap = { version = "4.4.6", features = ["derive"] } | 13 | clap = { version = "4.5", features = ["derive"] } |
14 | clap_complete = "4.4.4" | 14 | clap_complete = "4.5" |
15 | config = "0.13.3" | 15 | config = "0.14" |
16 | dirs = "5.0.1" | 16 | dirs = "5.0" |
17 | futures-util = "0.3.29" | 17 | futures-util = "0.3" |
18 | indicatif = "0.17.7" | 18 | indicatif = "0.17" |
19 | once_cell = "1.18.0" | 19 | reqwest = { version = "0.11", features = ["blocking"] } |
20 | reqwest = { version = "0.11.22", features = ["blocking"] } | 20 | serde = "1.0" |
21 | serde = "1.0.189" | 21 | serde_json = "1.0" |
22 | serde_json = "1.0.107" | 22 | tokio = { version = "1.36", features = ["macros", "rt-multi-thread", "io-std"] } |
23 | tokio = { version = "1.33.0", features = ["macros", "rt-multi-thread", "io-std"] } | 23 | tokio-tungstenite = "0.21" |
24 | tokio-tungstenite = "0.20.1" | ||