summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorFxQnLr <[email protected]>2022-12-26 21:57:03 +0100
committerFxQnLr <[email protected]>2022-12-26 21:57:03 +0100
commit0515548682a95db643a008146105d8ecdb446e58 (patch)
tree6622c5e6b0f97fe83aa559bda128d13947fe92b5 /Cargo.toml
parent43206da6f40027715582599baa0ad1c91477539e (diff)
downloadmodlist-0515548682a95db643a008146105d8ecdb446e58.tar
modlist-0515548682a95db643a008146105d8ecdb446e58.tar.gz
modlist-0515548682a95db643a008146105d8ecdb446e58.zip
changed config to toml, autocreate config;
better error handling
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 13280a1..c1de0fc 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,6 @@
1[package] 1[package]
2name = "modlist" 2name = "modlist"
3version = "0.6.1" 3version = "0.6.2"
4edition = "2021" 4edition = "2021"
5 5
6# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html 6# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
@@ -10,8 +10,8 @@ reqwest = { version = "0.11", features = ["json", "stream"] }
10tokio = { version = "1", features = ["full"] } 10tokio = { version = "1", features = ["full"] }
11serde = { version = "1.0", features = ["derive"] } 11serde = { version = "1.0", features = ["derive"] }
12serde_json = "1.0.87" 12serde_json = "1.0.87"
13config = "0.13.2"
14rusqlite = { version = "0.28.0", features = ["bundled"] } 13rusqlite = { version = "0.28.0", features = ["bundled"] }
15futures-util = "0.3.14" 14futures-util = "0.3.14"
16chrono = "0.4.22" 15chrono = "0.4.22"
17toml = "0.5.10" 16toml = "0.5.10"
17error-chain = "0.12.4"