diff options
author | FxQnLr <[email protected]> | 2023-11-06 11:09:34 +0100 |
---|---|---|
committer | GitHub <[email protected]> | 2023-11-06 11:09:34 +0100 |
commit | 1cd2a8e4aecfaad2a8385a6bea61580209b86398 (patch) | |
tree | c357bcaca0681caf9a6742c857bb494dc4315900 /Cargo.toml | |
parent | d9d7b125e4fcaa3aedd7b57a69e6880e012ccf33 (diff) | |
parent | 32561060a8dc6fc6118498da06bdd8f5b4c3f0fd (diff) | |
download | webol-1cd2a8e4aecfaad2a8385a6bea61580209b86398.tar webol-1cd2a8e4aecfaad2a8385a6bea61580209b86398.tar.gz webol-1cd2a8e4aecfaad2a8385a6bea61580209b86398.zip |
Merge pull request #6 from FxQnLr/ping
Ping
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 18 |
1 files changed, 11 insertions, 7 deletions
@@ -1,18 +1,22 @@ | |||
1 | [package] | 1 | [package] |
2 | name = "webol" | 2 | name = "webol" |
3 | version = "0.1.0" | 3 | version = "0.2.0" |
4 | edition = "2021" | 4 | edition = "2021" |
5 | 5 | ||
6 | # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html | 6 | # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html |
7 | 7 | ||
8 | [dependencies] | 8 | [dependencies] |
9 | axum = { version = "0.6.20", features = ["headers"] } | 9 | axum = { version = "0.6.20", features = ["headers", "ws"] } |
10 | tokio = { version = "1.32.0", features = ["macros", "rt-multi-thread"] } | 10 | tokio = { version = "1.33.0", features = ["macros", "rt-multi-thread"] } |
11 | tracing = "0.1.37" | 11 | tracing = "0.1.40" |
12 | tracing-subscriber = { version = "0.3.17", features = ["env-filter", "local-time", "time"] } | 12 | tracing-subscriber = { version = "0.3.17", features = ["env-filter", "local-time", "time"] } |
13 | time = { version = "0.3.29", features = ["macros"] } | 13 | time = { version = "0.3.30", features = ["macros"] } |
14 | serde = { version = "1.0.188", features = ["derive"] } | 14 | serde = { version = "1.0.190", features = ["derive"] } |
15 | serde_json = "1.0.107" | 15 | serde_json = "1.0.107" |
16 | config = "0.13.3" | 16 | config = "0.13.3" |
17 | once_cell = "1.18.0" | 17 | once_cell = "1.18.0" |
18 | sqlx = { version = "0.7.1", features = ["postgres", "runtime-tokio"]} | 18 | sqlx = { version = "0.7.2", features = ["postgres", "runtime-tokio"]} |
19 | surge-ping = "0.8.0" | ||
20 | axum-macros = "0.3.8" | ||
21 | uuid = { version = "1.5.0", features = ["v4", "fast-rng"] } | ||
22 | dashmap = "5.5.3" | ||